Mero Technologies - Users are unable to login – Incident details

All systems operational

Users are unable to login

Resolved
Operational
Started 9 months agoLasted 21 minutes

Affected

New Mero Control Centre

Operational from 7:11 PM to 7:32 PM

Updates
  • Resolved
    Resolved

    The issue has been resolved. Logins are restored.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.