Mero Technologies - Visit Processing Delay - October 20, 2025 – Incident details

All systems operational

Visit Processing Delay - October 20, 2025

Resolved
Degraded performance
Started 18 days agoLasted about 6 hours

Affected

Mero Control Centre

Degraded performance from 3:00 PM to 8:53 PM

API

Degraded performance from 3:00 PM to 8:53 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    Our team continues to work on the issue. No visit records appear to be lost but there is a delay.

  • Identified
    Identified

    We're experiencing a temporary delay in processing cleaner visit records. All data is being collected safely and will be processed automatically. No action needed on your end. We'll notify you once resolved.